Modulation

日常で気になる物や事柄をつづっています お気軽にコメントや足跡残して下さいm(_ _)m

Raspberry PI2 に Ubuntuを導入してNasにして見た 

QNAPSが容量不足の警告が出て調べてみたら 
USB HDDで QNAPSに EXfatフォーマットで接続し使用していた積りになったのが
 実際は 内部のHDDに USBと言うフォルダーを作って 外付けUSBのHDDは全く認識していない。
ここ数年使ってないのが判明したのです。 

 Raspberry PI2買ってNasの動画再生するのにRaspbianにKODI入れて納得して
何も使ってないです。

 QNapsの容量不足を解消するのに Raspberry PI2でUSB HDD3TBでNasにして見よう。

<使用機器>
Raspberry PI2 B
MicroSD8G 
使用していない時に電源切れる方が良いので
USB2.0で電源連動のついてるGW3.5AA-SUP/MB

キーボード、マウス、モニター
P_20170218_203626_vHDR_Auto[1]

<1回目、2回目>
Raspbian導入...
ググって見てると SDカードの最大まで使うと良いと?
SD内のエリアを消して作り直すなどを説明されている
そのままだとSDの4Gしか使えないとかあるので参考にして 
謎のコマンド sudo fdiskで
なんちゃらと記載されているのをそのまま実行 
Rebootすると起動しないヾ(゚Д゚ )ォィォィ

<3回目> 
1.Raspbian導入

2.ExFatでwindows10PCでHDDをフォーマット
 
3.ExFat利用のアプリを導入
sudo apt-get install exfat-fuse
導入後再起動してHDDを接続したら認識した。

4.SAMBA導入
sudo apt-get install samba

SAMBAにHDDを接続 
接続はHDDをつないだら認識していた個所をそのまま指定しました。
sudo nano /etc/samba/smb.conf

5.稼働してみる
速度はあまり出ないけど利用できる。。。。。
しばし データを移行???????タイムアウト??
3Gbのファイルとか大きなファイルをCopyするとエラーになる
1.5Gとかだと問題ないです
HDDをPCにつないで エラーになる ファイルをCopyするとOK
Raspberry PIにつないで PCから読み込むと問題無く利用できる。
Raspberry PIでNasとして利用できない?

<4回目>
Raspbianだとダメなのか?とUbuntuを試してみる 
1.Ubuntu導入

2.ExFat利用のアプリを導入
sudo apt-get install exfat-fuse
導入後再起動してHDDを接続したら認識した。

3.SAMBA導入
sudo apt-get install samba
SAMBAにHDDを接続 

4.稼働してみる
エラーになったファイルは他のPCから読み込みOK
他の2.5Gbのファイルを書き込みしてみる。。。
エラーになった 使えね~

<5回目>
この時点で ExFatのHDDにかなりのデータを移動していたのですが
Raspberry PIでExfatのHDDだと
事実上 大きなファイルは扱えないのでは?
1.ExfatのHDDのなかを Nasに戻す。

2.Ubuntu導入

3.GParted導入
Fdiskの謎のコマンドわかりにくいので Guiが使える
GPartedを利用しました。
sudo apt-get install gparted

4.HDDをExt4でフォーマット

5.SAMBA導入
sudo apt-get install samba
SAMBAにHDDを接続 

6.他のNas(Qnap)からCopyして稼働してみる
遅いけど 3Gのデータを問題無く書込み出来る。

7.リモートディスクトップ導入
Nasとして利用するのに キーボードやマウスは繋ぎたくないので導入
sudo apt-get install lxde

---------------------------------------------------------------------
ここまで 作業時間 延べ3週間かかりました。

HDDを Ext4でフォーマットしてしまったので
Qnapに繋いだら
USBDisk1として認識した。
[ 2017/02/20 05:00 ] PC | トラックバック(-) | CM(0)

Zenfone3 PoBox5.4 入れてみた 

Docomo SC-03D Galaxy Tab 7.0 PlusにAndroid 6.0を入れた時に
Pobox5.1に入れて ついでにネットを検索すると 
Pobox5.4.Zipが転がってました。
Screenshot_20170201-084325[1]

Zenfone3に パッケージを3つ順にインストールして言語の設定でPoBoxに切り替え
Screenshot_20170201-084524[1]
Screenshot_20170201-084538[1]

特に問題く利用できました。
Screenshot_20170201-084649[1]

[ 2017/02/05 23:34 ] モバイル | トラックバック(-) | CM(0)
FC2カウンター


現在の閲覧者数: